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Overview
This guide provides information on software prerequisites and requirements to install and uninstall Dell Smart Plug-in 
(SPI) Version 3.0 for Hewlett Packard Operations Manager (HPOM) 9.0 for Microsoft Windows.

NOTE: This plug-in is applicable for 64–bit systems.

The Dell SPI installer (Dell Smart Plug-in v3.0_x64.msi), Installation Guide and the Readme file are packaged in the self-
extracting executable Dell Smart Plug-in v3.0_Axx.exe file. You can download the executable from support.dell.com.

Read the Dell SPI's readme file, which contains the latest information about software and management server 
requirements, in addition to information about known issues. The readme file is also posted to the Systems Management 
documentation page at support.dell.com/manuals.
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Prerequisites
The prerequisites for installing the Dell Smart Plug-in are as follows:

• Install Dell SPI only on HPOM management server

• Administrator and HP_OVE_ADMIN privileges on the HP Operations Manager (HPOM) management server

• WinRM privileges to monitor Dell ESXi systems

• .Net Framework 3.5

Software Requirements For Management Server
The following table lists the software requirements on the management server.
Table 1. Software Requirements For Management Server

Requirement Description

HPOM 9.0 for Windows with the latest patches For more information on installing HPOM, see the HP 
Operations Manager 9.0 Installation Guide available on 
the HP support website.

Trap Interceptor with SNMPv2 If you want to monitor the Dell EqualLogic devices, then 
configure the HPOM trap interceptor to receive SNMPv2 
traps. For more information, see Configure SNMP 
conditions section in HP Operations Manager online help.

SNMP Service Install and enable SNMP. For more information, see
Related Documents.

WinRM 2.0 service Install and configure WinRM version 2.0 or later to 
establish communication with the Dell ESXi systems that 
you are monitoring. For more information, see Configuring 
User Authorization For WinRM.

Dell Connections License Manager Install and configure the licensing server. For more 
information, see Dell Connections License Manager 
Installation Guide at support.dell.com/manuals.

Software Requirements For Managed Systems
The following table lists the requirements for the managed systems.

NOTE: Ensure that DNS is configured properly for all managed systems.

Table 2. Software Requirements For Managed Systems

Requirement Description

Operating Systems Install the supported Microsoft Windows or Linux OS, or 
the supported ESXi version. For more information on the 
supported operating systems, see Related Documents.

SNMP service Install and enable the SNMP service and ensure that the 
management server can communicate with the managed 
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Requirement Description

node. For more information, see Related Documents and 
What To Do Next?

SNMP agent Configure the SNMP agent to change the community 
name, enable Get operations, and send traps to the HPOM 
management server.
Configure the SNMP service trap destination to receive 
traps on the management server.
For more information on configuring the SNMP agent on 
Windows and Linux systems, see Related Documents.

Server Administrator The supported versions of Server Administrator are:

• For Windows systems — versions 6.2 to 7.1
• For ESXi and Linux systems — versions 6.2 to 7.1

Install Server Administrator on ESXi and enable the OEM 
CIM providers and ensure that the management server 
can communicate with the systems.
For more information on configuring SNMP for Windows, 
ESXi, and Linux systems, or on enabling the OEM CIM 
providers, see Related Documents.

Supported Firmware Versions
The following table lists the supported firmware versions for DRAC, iDRAC, CMC, DRAC/MC, EqualLogic, and MD 
Storage Array devices.
Table 3. Supported Firmware Versions For DRAC, CMC, EqualLogic and MD Storage Array Devices

Dell Device Firmware Versions Supported

iDRAC6 11G Monolithic 1.8 and 1.9

iDRAC6 11G Modular 3.3 and 3.4

iDRAC7 1.10.10 and 1.20.20

DRAC 5 1.5 and 1.6

CMC 4.0 and 4.1

DRAC/MC 1.5 and 1.6

EqualLogic 5.2.1 and 5.2.2

MD Storage Array 7.35 (MD3000), 7.75, and 7.80 (all others including Hogs 2.0)

Configuring User Authorization For WinRM
To configure user authorization for WinRM:

1. Click Start → Run on the Windows menu of the system.

2. Type winrm configsddl default and click OK.

3. Click Add to add the required local or domain users or groups to the list.

4. Provide the appropriate permission(s) to the respective users and click OK.
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Installing The Dell SPI
NOTE: You must close the HPOM console before you install Dell SPI.

To install the Dell SPI on the HPOM management server:

1. Download the Dell SPI installer from the Dell support website at support.dell.com .
2. Extract the contents of Dell Smart Plug-in v3.0_Axx.exe on the management server.
3. Run the Dell Smart Plug-in v3.0_x64.msi.
4. In the Welcome screen, click Next.
5. Select the I accept the terms in the license agreement option and click Next.
6. In the custom screen, select one or both of these options

– Monitor Dell Servers, DRACs, Chassis
– Monitor Dell Storage

7. Click Next.
8. Select Yes to auto-deploy the policy files during installation. To deploy them manually on the management server, 

select No.
The Summary screen displays information about the Dell SPI installation location, deployed policy files, and the 
tools that are installed by the Dell SPI.

9. Click Install.
10. Click Finish.

Verifying The Dell SPI Installation
To verify the Dell SPI installation:

1. Launch the HPOM console and verify that the following hierarchies are created:

– Services Hierarchy

* Dell Hardware

a. Dell Chassis

1. CMC

2. DRAC/ MC

b. Dell DRAC

1. DRAC5

2. iDRAC6 Modular

3. iDRAC6 Monolithic

4. iDRAC7 Modular

5. iDRAC7 Monolithic

c. Dell Servers

1. ESXi Servers

2. Linux Servers

3. Windows Servers

d. Dell Storage
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1. EqualLogic PS-Series Arrays

2. PowerVault MD Storage Arrays

– Nodes Hierarchy

* Dell Managed Systems

a. Dell Chassis

1. CMC

2. DRAC/ MC

b. Dell DRAC

1. DRAC5

2. iDRAC6 Modular

3. iDRAC6 Monolithic

4. iDRAC7 Modular

5. iDRAC7 Monolithic

c. Dell Servers

1. Modular Servers

2. Monolithic Servers

d. Dell Storage

1. EqualLogic PS-Series Arrays

2. PowerVault MD Storage Arrays

e. Dell Unresponsive Devices
2. Navigate to Policy Management → Policy Groups → SPI for Dell Devices. 

a) Verify that the following are present under SPI for Dell Devices:

* Dell Connections License Manager Scheduled Status Poll
* Dell Server
* Dell Storage
* Dell Hardware Autogroup Policy

b) Verify that the following policies are present under SPI for Dell Devices → Dell Server :

* Dell DRAC and Chassis Scheduled Status Poll
* Dell DRAC and Chassis Traps (Manual Ack)
* Dell OOB Server Traps (Manual Ack)
* Dell Server Scheduled Status Poll
* Dell Server Traps
* Dell Server Traps (Manual Ack)

c) Verify that the following policies are present under SPI for Dell Devices → Dell Storage :

* Dell EqualLogic Arrays Scheduled Status Poll
* Dell EqualLogic Traps
* Dell EqualLogic Traps (Manual Ack)
* Dell MD Storage Arrays Scheduled Status Poll

3. Verify that the auto-deployed policies are present in the Policy Inventory.
Under Nodes, right-click on the management server, and select View → Policy Inventory to view the following 
policies:
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– Dell DRAC and Chassis Scheduled Status Poll
– Dell DRAC and Chassis Traps (Manual Ack)
– Dell EqualLogic Arrays Scheduled Status Poll
– Dell EqualLogic Traps
– Dell Hardware Autogroup Policy
– Dell MD Storage Arrays Scheduled Status Poll
– Dell OOB Server Traps (Manual Ack)
– Dell Server Scheduled Status Poll
– Dell Server Traps
– Dell Connections License Manager Scheduled Status Poll

4. Verify that the following tools are displayed under their respective folders under Tools.
a) The following tools are displayed under Tools → Dell Tools. 

* Dell Chassis
* Dell DRAC
* Dell Server
* Dell SPI Licensing
* Dell Storage
* OpenManage Essentials Console
* OpenManage Power Center Console
* Warranty Report

b) The following tools are displayed under Tools → Dell Tools → Dell Chassis.

* CMC Console
* DRAC/MC Console

c) The following tools are displayed under Tools → Dell Tools → Dell DRAC.

* DRAC Console
* OpenManage Server Administrator Console

d) The following tools are displayed under Tools → Dell Tools → Dell Server.

* Dell Remote Access Controller Console (in-band)
* OpenManage Server Administrator Console
* OpenManage Server Administrator Web Server Console

e) The following tools are displayed under Tools → Dell Tools → Dell SPI Licensing

* Dell Connections License Manager Console Launch Tool
f) The following tools are displayed under Tools → Dell Tools → Dell Storage.

* Dell EqualLogic PS-Series Arrays

• Equallogic Group Manager Console
* Dell PowerVault MD Storage Arrays

• MD Storage Manager Console
5. Verify that the Dell SPI config utility is installed in the default or the custom directory. The default location is:

C:\Program Files\Dell\OpenManage Connection for HP\.

If any of the step fails, check the prerequisites and try again. To use the Modify, Repair, and Remove options in the 
installer, see:

– Using The Modify Option In The Installer
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– Using The Repair Option In The Installer

– Removing Dell SPI Using The Installer
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What To Do Next?
After you complete installing the Dell SPI, configure the SNMP parameters for Dell Windows, Linux Servers, Dell DRAC, 
Dell Chassis, EQL devices, DCLM parameters for OOB server monitoring, and WSMAN parameters for ESXi systems to 
ensure that communication between the management server and the Dell systems is established correctly. To configure 
the communication parameters, run the DellSPICongfigUtility.exe that is part of the Dell SPI installer.

You can configure the following:

• SNMP timeout and retries

• Server Administrator Web Server Console URL

• Warranty Report URL

• DCLM Parameters:

– Webservice URL
– Username
– Password

• WSMAN Connection Parameters:

– Username
– Password
– Timeout

– Security options that include Certificate Authority check, Common Name check, and Revocation check

NOTE: You can configure the Warrany Report URL, DCLM Webservice URLand the Server Administrator Web 
Server Console URL according to the environment.

The following table lists the command line options to set the different values for SNMP, Server Administrator Web 
Server Console URL,WSMAN, DCLM, and Warranty Report URL.

Table 4. Command Line Options

Option Description

-snmptimeout Specifies the SNMP timeout in milliseconds. The default 
value is 5000 (5 seconds). Set a value between 100 
milliseconds to 4294967290 milliseconds.

-snmpretries Specifies the number of SNMP retries. The default value 
is 1.

- dwsurl Specifies the DWS URL.

-dclmwebserviceurl Specifies the DCLM webservice URL.
Example: http://dclmserver.domain.com:8543/

-dclmusername Specifies the dclm username for logging in with basic 
authentication.
Example: domain\username

-dclmpassword Specifies the dclm password for logging in with basic 
authentication.

-getall Specifies the values of all the options and display them on 
the screen. This option gets all the values for all the 
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Option Description

individual parameters except wsmanusername, 
wsmanpassword,dclmusernameand 
dclmpassword and displays them on the screen.

-resetdefaults Resets all the configurable values to the default values.

NOTE: This option does not reset the values for the-
wsmanusername,-
wsmanpassword,dclmusernameand 
dclmpassword options.

-help Displays the help for using this tool.

-wsmanusername Specifies user name of a local or a domain account on the 
ESXi system. This property determines the user name for 
authentication to access the ESXi system.

-wsmanpassword Specifies the password for the user name you specified.

-wsmancacheck Skips the authentication of Certificate Authority that 
issued the certificate. The value is eitheryes or no. The 
default value is no. If you set the value to yes, then the 
authentication of Certificate Authority is checked.

-wsmancncheck Skips authentication of the Common Name (CN). The 
value is either yes orno. The default value is no. If you 
set the value to yes, then the common name is checked.

-wsmanrevocationcheck Specifies a value to indicate whether the WSMAN 
connection should validate the revocation status of the 
server certificate or not. The value is either yes orno. 
The default value is no. If you set the value to yes, then 
the revocation status of the server certificate is checked.

-wsmantimeout Specifies WSMAN timeout value in milliseconds. The 
default value is 30000 (30 seconds). Set a value between 
500 milliseconds to 4294967290 milliseconds.

Using The Dell SPI Configuration Utility
To use the configuration utility:

1. Launch a command prompt on the management server.

2. Navigate to DellSPIConfigUtility.exe . The default location is C:\Program Files\Dell\OpenManage Connection for HP.

3. Type the following command:
DellSPIConfigUtility.exe -<option>=<value> and press Enter.

For example, if you want to set the WSMAN timeout, type the following command: 
DellSPIConfigUtility.exe -wsmantimeout=500

NOTE: If you enter invalid values, the utility displays the error message with the help text.

You must set the values for wsmanusername and wsmanpassword if you are monitoring the ESXi systems. 
You must also set the value for the Web Server Console.
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When you specify the value for wsmanpassword , type the following command: 
DellSPIConfigUtility.exe -wsmanpassword and press Enter. You do not need to specify = after -
wsmanpassword. When you specify the password for the first time, you need to enter the password twice. When 
you modify the password, the utility prompts you to enter the old password and then the new password twice.

NOTE: The utility prompts you to change the password even when you change the username.

To view the values for each option other than the values for wsmanusername and wsmanpassword, type the 
following command: DellSPIConfigUtility.exe -<option>

Configuring Dell Connections License Manager Parameters
To configure the Dell Connections License Manager (DCLM) parameters:

1. Install the Dell Connections License Manager. For more information, see Dell Connections License Manager 
Version 1.0 Installation Guide at support.dell.com/manuals.

2. Launch the command prompt on the management server.

3. Navigate to DellSPIConfigUtility.exe . The default location is C:\Program Files\Dell\OpenManage Connection for HP.

4. Set the Dell Connections License Manager web service url by typing the following command:
DellSPIConfigUtility.exe -dclmwebserviceurl=<License Server IP>:<port 
number>
For example: DellSPIConfigUtility.exe -dclmwebserviceurl=http://
10.56.123.255:8543

5. Set the Dell Connections License Manager username by typing the following command:
DellSPIConfigUtility.exe -dclmusername=<username>
The utility prompts you to enter the Dell Connections License Manager password.

6. Enter the password.
You have to re-enter the password to verify if you have entered the password correctly.

When you modify the password, the utility prompts you to enter the old password and then the new password 
twice.

NOTE: The command used to set the Dell Connections License Manager password is 
DellSPIConfigUtility.exe -dclmpassword. You do not have to specify = after -
dclmpassword.

NOTE: The utility prompts you to change the dclmpassword when you change the dclmusername.

Configuring Dell Connections License Manager URL
1. Select Tools → Dell Tools → Dell SPI Licensing → Dell Connections License Manager Console Launch Tool. 

2. On the right pane, select Dell Connections License Manager Console Launch Tool and right-click, and then click 
Properties from the pop-up menu.
The Dell Connections License Manager Console Launch Tool Properties window is displayed.

3. In the Dell Connections License Manager Console Launch Tool Properties window, click the Details tab.

4. In the URL: (Required) box, enter the URL path of the Dell Connections License Manager Console.
Example: http://mylicenseserver.mydomain.com:8544/DellLicenseManagement

5. Click Apply.

6. Click OK.
The Dell Connections License Manager Console Launch Tool is configured on the HPOM Console.
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Configuring Modular Disk (MD) Storage Manager Console
1. Install the Modular Disk (MD) Storage Manager Client on the management server.

2. Select Tools → Dell Tools → Dell Storage → Dell PowerVault MD Storage Arrays.

3. On the right pane, select MD Storage Manager Console and right-click, and then click Properties from the pop-up 
menu.
The MD Storage Manager Console Properties window is displayed.

4. In the MD Storage Manager Console Properties window, click the Details tab.

5. In the Command Type: (Required) drop-down list, click Executable.

6. Obtain the path of Modular Disk Storage Manager Client.exe. 
The default path is C:\Program Files (x86)\Dell\MD Storage Software\MD Storage Manager\client\Modular Disk 
Storage Manager Client.exe.

7. In the Command: (Required) box, enter the Modular Disk Storage Manager Client.exe location details or click 
Browse to navigate to the location where you installed the Modular Disk Storage Manager Client.exe file.

8. Click Apply.

9. Click OK.
The MD Storage Manager Console is configured on the HPOM Console.

Configuring OpenManage Power Center (OMPC) Tool
1. Install the OpenManage Power Center (OMPC). For more information, see Dell OpenManage Power Center Version 

1.1 User's Guide at support.dell.com/manuals.

2. In the HPOM console, select Tools → Dell Tools.

3. On the right pane, select OpenManage Power Center Console and right-click, and then click Properties from the 
pop-up menu.
The OpenManage Power Center Console Properties window is displayed.

4. In the OpenManage Power Center Console Properties window, click the Details tab.

5. In the Command Type: (Required) drop-down list, select URL.

6. In the Command: (Required) box, enter the URL path of the OMPC Console.
The default URL path is https://localhost:8643/powercenter

NOTE: OMPC Console will launch successfully using the default URL only if OMPC is installed on the same 
HPOM server. If OMPC is installed on another server then, obtain the URL from the respective OMPC server 
where OMPC is installed, and set the OMPC URL.

– Example: https://10.94.145.132:8643/powercenter

– Example: https://hpom1w2k8r2.hpdom.com:8643/powercenter

7. Click Apply.

8. Click OK.
The OMPC Console is configured on the HPOM Console.

Configuring OpenManage Essentials (OME) Tool
1. Install the OpenManage Essentials (OME). For more information, see Dell OpenManage Essentials Version x.x 

User's Guide at support.dell.com/manuals.

2. In the HPOM console, select Tools → Dell Tools.
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3. On the right pane, select OpenManage Essentials Console and right-click, and then click Properties from the pop-
up menu.
The OpenManage Essentials Console Properties window is displayed.

4. In the OpenManage Essentials Console Properties window, click the Details tab.
5. In the Command Type: (Required) drop-down list, select URL.
6. In the Command: (Required) box, enter the URL path of the OME Console.

The default URL path is https://localhost:2607/Web/Default.aspx

NOTE: OME Console will launch successfully using the default URL only if OME is installed on the same HPOM 
server. If OME is installed on another server then, obtain the URL from therespective OME server where OME 
is installed, and set the OME URL.

– Example: https://<IP Address Or Fully Qualified Domain Name>:2607/Web/Default.aspx

– Example: https://10.94.149.172:2607/Web/Default.aspx

– Example: https://hpom1w2k8r2.hpdom.com:2607/Web/Default.aspx
7. Click Apply.
8. Click OK.

The OME Console is configured on the HPOM Console.

Setting The Schedule For Auto-grouping Policy
To set the schedule for auto-grouping policy:

1. Click Policy Management → Policy Groups → SPI for Dell Devices. 
2. Select Dell Hardware Autogroup Policy.
3. Right-click and select All Tasks → Edit.

The Dell Hardware Autogroup Policy [3.0] (Scheduled Task) screen is displayed.

4. In the Schedule tab, select any of the options in the drop-down menu, and input the desired schedule.
5. Click Save, and Close.

NOTE: Deploy the Dell Hardware Autogroup Policy on the management server after setting the schedule. For 
more information on deploying the Dell Hardware Autogroup Policy, see Dell Smart Plug-in Version 3.0 for HP 
Operations Manager 9.0 For Microsoft Windows User's Guide.
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Creating Connections License Manager Domain 
Groups
The following groups are created in the Windows Server Active Directory during installation of Dell Connections License 
Manager:

• Dell Connections License Administrators

• Dell Connections License Operators

• Dell Connections License Users

If the above domain groups are not automatically created during installation, then manually create the above groups. To 
create domains and add users to domains, see the Windows documentation from Microsoft at technet.microsoft.com .

NOTE: After creating the required domain groups add your Management Server Machine Account as part of the 
Dell Connections License Users group and add the current user account to the Dell Connections License 
Administrators group.
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Removing Dell Devices
To remove a Dell device from the HPOM console:

1. Remove a Dell device from the HPOM console. To remove a Dell device from the HPOM console, see the section 
Delete, copy, and move managed nodes under Maintaining nodes in the HP Operations Manager online help.

2. If you are deleting an iDRAC7 device, perform the following steps:

a. Launch the command prompt on the management server.

b. Navigate to DellSPIConfigUtility.exe . The default location is C:\Program Files\Dell\OpenManage Connection 
for HP.

c. Type the following command:
DellSPIConfigUtility.exe —relinquish=<iDRAC7 device servicetag>

NOTE: The iDRAC7 device service tag can be retrieved either from the Dell Hardware service hierarchy or from the 
iDRAC7 server manually.

17



Using The Modify Option In The Installer
The Modify option in the Dell SPI installer, modifies the program features that are installed. This option retains the 
schedules you have set for the various policies.

To modify the program features:

1. Disable all the Dell SPI policies that are running on the management server in the HP Operations Manager (HPOM) 
console.

2. Run the Dell Smart Plug-In v3.0_x64.msi from the extracted folder.
The Welcome screen is displayed.

3. Click Next.
The installer displays three options.

4. Select the Modify option and click Next.
The Custom screen is displayed.

5. In the custom screen, select — Monitor Dell Servers, DRACs, Chassis, or Monitor Dell Storage to modify the 
feature you had installed earlier.
The Ready to Modify screen is displayed.

6. Click Install.

7. When the installation process completes, click Finish.

Modifying The Dell SPI Using Windows Control Panel
To modify the Dell SPI program features using Windows Control Panel:

1. Disable all the Dell SPI policies that are running on the management server in the HP Operations Manager (HPOM) 
console.

2. From the Start menu, select Settings → Control Panel → Programs → Uninstall a program.

3. In Uninstall or change a program, select Dell Smart Plug-in v3.0 and click Change.

4. Click Next.
The installer displays three options.

5. Select the Modify option and click Next.
The Custom screen is displayed.

6. In the custom screen, select — Monitor Dell Servers, DRACs, Chassis, or Monitor Dell Storage to modify the 
feature you had installed earlier.
The Ready to Modify screen is displayed.

7. Click Install.

8. When the installation process completes, click Finish.
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Using The Repair Option In The Installer
If you accidentally delete any of the policies from the SPI for Dell Devices policy group, or from the Policy Inventory of 
the management server, use the Repair option in the Dell SPI installer to re-install the policies.

The Repair option installs the missing Dell SPI policies, and automatically deploys all the policies on the management 
server. Before you use the Repair option, ensure that you remove or undeploy all the Dell SPI policies from the HPOM 
management server node on the HPOM console.

NOTE: If you modify any of the policies and then delete them, the Repair option installs only the original version of 
the policies. You must modify them again as per the requirements. The repair option resets the values of the SNMP, 
WSMAN, DWSURL, DCLM Webservice URL and Warranty Report URL parameters to the default values. You must 
set the values of the parameters again.

Additionally, if any of the files are missing or corrupted, the Repair option replaces the file.

Repairing The Program Features
To repair the program features:

1. Run the Dell Smart Plug-In v3.0_x64.msi from the extracted folder.
The Welcome screen is displayed.

2. Click Next.
The installer displays three options.

3. Select the Repair option and click Next.
The Ready to Repair screen is displayed.

4. Click Install.
When the installation process completes, click Finish.

Repairing The Dell SPI Program Features Using Windows Control 
Panel
To repair the Dell SPI Program Features using Windows Control Panel:

1. From the Start menu, select Settings → Control Panel → Programs → Uninstall a program.
2. In Uninstall or change a program, select Dell Smart Plug-in v3.0 and click Repair.
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Upgrading From Dell SPI Version 2.0 And 2.1
If you have Dell SPI version 2.0 or 2.1 installed on the management server, you can upgrade the same to version 3.0.

When you upgrade from version 2.0 or 2.1, the existing policies upgrade to the version 3.0 and the existing Dell groups 
from nodes and services are removed and recreated automatically.

NOTE: The Upgrade process does not preserve the schedule settings for the policy files. The schedules are reset 
to the default settings.

Upgrading Dell SPI
1. Remove or undeploy all the Dell SPI policies from the HPOM management server node on the HPOM console.
2. Close the HPOM console.
3. Run the Dell Smart Plug-In v3.0.msi from the extracted folder.

The Welcome screen is displayed. You are also prompted with a message that another version of Dell SPI is 
installed and whether you want to upgrade to a newer version.

4. Click Yes to proceed with the installation.
5. Follow steps 6 - 8 mentioned in Installing The Dell SPI.

NOTE: After the upgrade process is complete, the Auto-grouping policy runs automatically to group the Dell 
devices.
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Uninstalling The Dell SPI
You can uninstall the Dell SPI from the Windows Control Panel or use the Remove option in the Dell SPI installer. 
Uninstall removes Dell SPI components such as files, registry, and scripts from the installed system.

Before you uninstall Dell SPI, ensure the following:

• Dell policies are not running on the management server.

• All the Dell SPI policies are either removed or undeployed from the HPOM management server node on the 
HPOM console.

• The Dell SPI directories are closed.

CAUTION: Uninstall the Dell SPI before you uninstall HPOM. If you uninstall HPOM first and then attempt to 
uninstall the Dell SPI, the uninstallation process may fail with errors.

NOTE: When you uninstall the Dell SPI, the following errors are displayed:

• One or more Dell SPI processes in progress.

• Stop all Dell SPI processes and try again.

To resolve this, disable the policies, or wait till the policies complete, and then retry the uninstallation.

Removing The Dell SPI Using Windows Control Panel
To remove the Dell SPI using Windows Control Panel:

1. From the Start menu, select Settings → Control Panel → Programs → Uninstall a program.

2. In Uninstall or change a program, select Dell Smart Plug-in v3.0 and click Uninstall.
The Dell SPI v3.0 is removed from the HPOM management server.

Removing Dell SPI Using The Installer
To remove Dell SPI v3.0 using the installer:

1. Run the Dell Smart Plug-In v3.0_x64.msi from the folder where you extracted the contents of the self extracting 
package Dell Smart Plug-in v3.0_Axx.exe.
The Welcome screen is displayed.

2. Click Next.
The installer displays three options.

3. Select the Remove option and click Next.
The Remove the Program screen is displayed

4. In the Remove the Program screen, click Remove.
The Dell SPI v3.0 is removed from the management server.

Verifying The Uninstallation Of Dell SPI
To verify that the Dell SPI is completely uninstalled from the management server:
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1. Launch the HPOM console and ensure that the SPI for Dell Devices policy group under Policy Management → 
Policy Group is removed.

2. Click Nodes and ensure that the Dell Managed Systems Group is removed.
3. Click Service → System Infrastructure and ensure that the Dell Hardware service, Dell SPI Licensing service and 

the services tree for all Dell devices is removed.
4. Click Tools and ensure that the Dell Tools folder is removed.
5. Ensure that the Dell SPI installation directory is removed from the default or the custom path. The default path is:

C:\Program Files\Dell\OpenManage Connection For HP

6. Ensure that the Policies directory is removed. The default path is:
C:\Program Files\HP\HP BTO Software\install\DellSPIPolicy
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Related Documents
In addition to this guide, you can access the following guides available on the Dell support website at support.dell.com/
manuals. On the Manuals page, click Software → Systems Management. Click the appropriate product link on the right-
side to access the documents.

For example to view Dell SPI documentation on the Systems Management page, from the list of product, select Dell 
OpenManage Connections → Dell Smart Plug-in for HP Operations Manager Version 9.0 for Microsoft Windows

• Dell Smart Plug-in Version 3.0 For HP Operations Manager 9.0 For Microsoft Windows User’s Guide
• Dell OpenManage Server Administrator User’s Guide
• Dell OpenManage With VMware ESX/ESXi 4 Systems Management Guide
• Dell Chassis Management Controller User’s Guide
• Dell Integrated Remote Access Controller User’s Guide
• Dell Remote Access Controller 5 User’s Guide
• Dell Remote Access Controller/ Modular Chassis User's Guide
• Dell Connections License Manager Version 1.0 User's Guide
• Dell OpenManage Power Center Version 1.1 User's Guide
• Dell OpenManage Essentials Version x.x User's Guide
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