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Safety, Environmental, and Regulatory 
Information
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Features

1 Status LED 2 Thunderbolt™ 3 port

1
2

3

The Dell Portable Thunderbolt™ 3 SSD features a single LED indicator located on the left of the Thunderbolt™ 3 port. 

Use this to help determine the status of the device power and status of the internal cooling fan.

3 Thunderbolt™ 3 
connector
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The following table describes the status LED behavior on the SSD.

LED behavior Power Fan Activity

Blinking White ON ON Yes

White ON ON No

Blinking Amber ON Malfunction Yes

Amber ON Malfunction No

Off OFF NA NA
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Before using your device

NOTE: Safely eject the solid state drive in the operating system of your computer before 
unplugging the cable. See “Ejecting the solid state drive in Windows” or “Safely removing the 
solid state drive using the Thunderbolt™ 3 SSD Utility” for instructions.

CAUTION: Unplugging the portable solid state drive from your computer when the light 
indicator is blinking white may cause data loss or damage to your device.
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Introduction

Dell Portable Thunderbolt™ 3 SSD bus powered external SSD’s are high-performance, ultra-portable, and reliable 

storage solutions.  They are ideal for transferring large amounts of data quickly to help maintain productivity whether at 

home, in the workplace, or on the road. 

Use the Thunderbolt™ 3 SSD Utility to manage the drive.
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Getting Started

Connecting the solid state drive

Follow the procedure below to connect the drive to your computer.

1 Connect one end of the Thunderbolt™ 3 cable shipped with the device into 

the Thunderbolt™ 3 port on your computer. Connect the other end into the 

Thunderbolt™ 3 port on the Dell Portable Thunderbolt™ 3 SSD. A window will pop 

up after a few seconds. 

2 In the pop-up window you are asked if you want to allow the drive to connect to your 

system. Choose the Always Connect option from the drop down menu, and click OK.
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Disconnecting the solid state drive

CAUTION: 
The status LED turns white when the drive is connected. 

To remove the Dell Portable Thunderbolt™ 3 SSD, you have two options:

See “Ejecting the solid state drive in Windows” or “Safely removing the solid state drive using the Thunderbolt™ 3 SSD 

Utility”.

DO NOT disconnect the drive when the status LED is blinking. 
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Ejecting the solid state drive in Windows

To remove the Dell Portable Thunderbolt™ 3 SSD using Windows eject drive follow these steps:

1 Move the cursor to the Windows System Tray and choose the Eject option for the Dell Portable SSD. 

2 When the Safe To Remove Hardware message appears, disconnect the cable. 

Ejecting the solid state drive using the Utility

See “Thunderbolt™ 3 SSD Utility”.
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Thunderbolt™ 3 SSD Utility
The Dell Portable SSD Utility installation file in located on the drive, and also available to download at Dell.com/support. 

The Dell portable SSD works without additional software. It is recommended to install the software utility to monitor 

performance. You also need the utility to lock the SSD for security.

This PC

Installing the Thunderbolt™ 3 SSD Utility

1 Use Windows Explorer to open or view the drive. Double-click on This PC on the desktop, the drive is 

displayed along with other storage devices.

2 Double-click on the Thunderbolt™ 3 SSD Utility installation file located on the drive. Follow the instructions 

that appear. 

Dell.com/support
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Drive Status

The Status tab displays when the utility is launched. This is useful for checking how much storage capacity is available 

and provides information useful for troubleshooting. 

Using the Thunderbolt™ 3 SSD Utility 
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Tools

Security

Security is not enabled by default. When you use this security feature to lock the drive, you will create a password that 

must be entered to unlock it. The locked status continues after the drive is disconnected. That is, when the drive is 

connected again, you need to enter the password to unlock the drive. 

Each time you lock the drive, you need to complete the procedure to create a password. You can use the same 

password used in previous sessions. 

NOTE: When you lock the drive, you must create a password. Set a password that you can 

remember easily to unlock the drive.

CAUTION: Also keep in mind that you must remember this password to unlock the drive. 
There is no way to unlock the drive if you forget the password. It will be necessary to reset 
the drive if you forget your password. This means you will lose any data on the drive.  
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Locking the solid state drive

1 To lock the drive, go to the Tools menu and click on the Lock button. A new menu appears. 

2 Enter the password used to unlock the drive. Use a password that is difficult to guess, but one that you can 

remember. You cannot unlock the drive without the password. Retype the password in the space provided.

3 Click on the Submit button to create  the password and put the drive into locked status.
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Unlocking the drive

1 To unlock the drive, go to the Tools menu and click on the Unlock button. A new menu appears. 

2 Enter the password used to unlock the drive and click on the Submit button.
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If the password is forgotten, enter the PSID used to unlock the drive and click on the Submit button.

CAUTION: All data and password on the SSD will be erased, if unlock by PSID.

Unlocking the drive with PSID

NOTE: The PSID is printed on the bottom of the Dell Portable Thunderbolt™ 3 SSD, and 

on a sticker located inside the box shipped with the device. The sticker can be pealed 

off and placed as per your preference.
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Safely removing the solid state drive using the Thunderbolt™ 3 SSD Utility 

To safely remove the SSD using the Thunderbolt™ 3 SSD Utility, open the utility and click on the Eject Drive button at 

the top of the menu interface. 
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Performance

Use the Performance tab to test drive speed. 
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Help

Use the Help tab to view documentation and help information for the SSD. 
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Managing the solid state drive in Windows
You can use Windows Administrative Tools to partition or change the file system on the Dell Portable Thunderbolt™ 3 

SSD. 

Go to Control Panel (View by Small/Large icons) > Administrative Tools > Computer Management > Storage > 

Disk Management to access the Windows Disk Management interface.
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Troubleshooting

I cannot see Dell SSD Disk Volume when 

I insert Dell Portable SSD. What should 

I do?

Check the below items.

1 Thunderbolt™ 3 USB-C connector and Thunderbolt™ 3 Cable 

•	 Look for the Thunderbolt™lightning bolt logo on the 

platform. The port looks identical to the USB-C, but it is a 

Thunderbolt™ 3 connector. 

•	 Thunderbolt™ 3 cable should have a Thunderbolt™ lightning 

bolt logo with the numeral 3.

2 Thunderbolt™ 3 Software

a. Make sure that Thunderbolt™ 3 software is installed and 

running. If the software is running, the Thunderbolt™ 3 

software icon appears in the Windows System Tray.

b. To check if the Dell Portable SSD is detected and approved 

on the Thunderbolt™ software. 

 - Click on the right button of your mouse on software 

icon. 

 - Check devices on View Attached Devices / Approve 

Attached Devices (Always Connect) / Manage 

Approved Devices.

3 Disk Management

Problems Possible Solutions

a. Is the Dell Portable SSD Disk detected?

•	 If Disk is detected, check item 3(b) and 4.

•	 If Disk is NOT detected, check item 5, 6, and 7.

b. The file system of Dell Portable SSD should be supported by 

the OS.

Common symptoms

The following table contains information about common symptoms you might encounter and the possible solutions.
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 I cannot see Dell SSD Disk Volume 

when I insert Dell Portable SSD. What 

should I do?(continued):

Problems Possible Solutions

a. View -> Devices by Type -> Disk drives 

NVMe SSD of Dell Portable SSD detected or not detected.

b. View -> Devices by Type -> Storage Controllers  

Driver of NVM Express Controller of Dell Portable SSD is 

loaded or not loaded. 

If not, check item 6.

c. View -> Devices by Type -> System devices  

Thunderbolt™ Controller - 1575 of Dell Portable SSD is 

detected normally or not.

6 Device Status shows “Resource is not enough” in Device Manager 

System BIOS is responsible to allocate the memory resources for 

attached devices. Contact the manufacturer of the notebook or 

motherboard.

•	 Right-click your mouse on NVM Express Controller. 

•	 Choose Properties item.

•	 Go to General page.

•	 Check the description on Device Status.

7 Power Shortage

a. Remove other Thunderbolt™accessories and insert the SSD as 

the First (Primary) plug-in device to a Thunderbolt™ 3 port on 

the computer.

b. Install SD1-TSeries Portable SSD Utility first to diagnose the 

power supply for Dell Portable SSD automatically. If there is 

power shortage problem, a pop-up menu warns the user of the 

problem.

4 Security Locked

 Install SD1-TSeries Portable SSD Utility first to check the security  

 status of Dell Portable SSD. It can be unlocked by the Utility. 

•	 Open the Utility.

•	 Go to page TOOLS.

•	 Press the Unlock button.

•	 Input the password on Unlock SSD page, then Submit.

5 Device Manager
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Nothing displays when I launch the 

SD1-TSeries Portable SSD Utility.

What can I do if I forget the password 

for security function?

What should I do if the “Remaining 

Life” is showing a warning message

The user must have administrator privilege to open Utility. Login as 

administrator and open the Utility. 

Problems Possible Solutions

1 Look for PSID on Product Label.

2 Open the Utility.

3 Go to page TOOLS.

4 Press the Unlock button.

5 Input the PSID to the page Erase Recovery with PSID, then 

Submit.

Remaining Life refers to the endurance of the NAND flash. This is calculated 

by how much data has been written to the flash. It is a value estimated by the 

flash manufacturer.

If a warning message displays for the Remaining Life, to avoid data loss, it is 

recommended to back up any important data in the drive. If the Dell Portable 

SSD is still under warranty, it can be returned to the manufacturer. A Return 

Merchandise Authorization (RMA) order is required.

NOTE: The data and password on SSD will be erased, if the SSD is 

unlocked by PSID.
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What are the consequences if I turn 

off the TRIM function?

How to change Windows Disk volume 

to Mac platform?

How to change Mac Disk volume to 

Windows platform?

Problems Possible Solutions

It is likely that you will not get the optimal performance. Other SSD installed 

on your system with NTFS will be affected as well.

1 Open Disk Utility on Mac platform.

2 Erase Dell Portable SSD to macOS supported File System.

1 Open Command Prompt and execute diskpart to clean Dell 

Portable SSD.

2 Open Disk Management.

3 Initialize disk.

4 New volume for Dell Portable SSD. 

NOTE: Converting the file system will erase the entire contents of 

the drive. All data currently on the drive will be lost.

NOTE: Converting the file system will erase the entire contents of 

the drive. All data currently on the drive will be lost.
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What should I do if BSoD (Blue Screen 

of Death) with Stop Code 0x0000001A, 

MEMORY_MANAGEMENT, after hot-

plugging the Dell Portable SSD on 

Windows Platform?  

Dell Portable SSD should be safely removed using the Eject icon in the 

Windows System Tray or by SD1-TSeries Portable SSD Utility. Removing 

the Dell Portable SSD without following the proper eject procedure, then 

hot-plugging the Dell Portable SSD can cause the operating system BSoD. 

However, the SSD should still work well after a COLD BOOT together with 

your Windows platform.

To repair Dell Portable SSD and resolve the BSoD problem:

1 Connect the Dell Portable SSD to powered off Windows 

platform.

2 Power on the platform.

3 Back up data to another drives.

4 Format Dell Portable SSD.

Problems Possible Solutions

 NOTE: There is a very low 

probability of this occurring. 

However, if it happens, it 

will keep happening until the 

problem is corrected.
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What should I do if the Dell Portable SSD 

cannot be accessed after hot-plugging 

the Dell Portable SSD on Mac Platform?

Removing then hot-plugging the Dell Portable SSD can cause the Dell 

Portable SSD to be undetected or inaccessible. The SSD should still work 

after a cold boot on a Mac platform. 

Symptoms of failed detection:

Problems Possible Solutions

1 No Volume of Dell Portable SSD can be accessed. 

2 Under System Information, Driver Installed status is No.

 NOTE: There is a very low 

probability of this occurring. 

However, if it happens, it 

will keep happening until the 

problem is corrected.
For example: 

System Information->Hardware->PCI 

pci1179,116: 

Type: NVM Express Controller 

Driver Installed: No  
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What should I do if the Dell Portable SSD 

cannot be accessed after hot-plugging 

the Dell Portable SSD on Mac Platform? 

(continued)

Problems Possible Solutions

3 Under System Information, Thunderbolt™ bus would have the 

value SD1-T1000 Dell SSD / SD1-T0500 Dell SSD. 

To repair Dell Portable SSD and resolve the access problem:

1 Connect the Dell Portable SSD to a powered off Mac 

Computer.

2 Power on the platform.

3 Back up data to another drive.

4 Open Disk Utility.

5 Click View -> Show All Devices.

6 Unmount the volume of Dell Portable SSD.

7 Erase “KXG50ZNV512G NVMe TOSHIBA 512GB Media” or 

”KXG50ZNV1T02 NVMe TOSHIBA 1024GB Media” to macOS 

supported File System.

For example: 

System Information->Hardware->Thunderbolt™ Bus->SD1-T1000 

Dell SSD
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Specifications

General
Model number SD1-T0500, SD1-T1000

Storage Media 1TB NVMe SSD ( SD1-T1000)

512GB NVMe SSD ( SD1-T0500)

Connection Interface Thunderbolt™ 3

Rating
Operating Voltage 5V (2.4A)

Physical characteristics 
Weight 61 gm (2.1 oz)

Dimensions

Length 98.8 mm (3.89 in)

Width 48 mm (1.89 in)

Height 19 mm (0.75 in)

Environmental 
Operating temperature 0°C (32°F) to 35°C (95°F)

Operating humidity <95% relative humidity (non-condensing)

Certificates CE, VCCI, FCC, ACMA, IC, NRTL, CB

Warranty Three-year limited warranty

NOTE: For more information about Dell Warranty and Support 
Policy go to Dell.com.

System Requirements Desktop or notebook computer with a Thunderbolt™ 3 port and one of the 
following operating systems:

•	 Windows 10 x64

•	 Mac OS X 10.13 or later

NOTE: Speed varies depending on host hardware, software, usage, and storage capacity.

Dell.com
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Statutory information

Warranty

Limited warranty and return policies

The Dell Portable Thunderbolt™ 3 SSD, carry a 3-year limited hardware warranty. If purchased together with a Dell 

system, it will follow the system warranty.

For U.S. customers:

This purchase and your use of this product are subject to Dell’s end user agreement, which you can find at Dell.com/

terms. This document contains abiding arbitration clause.

For European, Middle Eastern and African customers:

Dell-branded products that are sold and used are subject to applicable national consumer legal rights, the terms of any 

retailer sale agreement that you have entered into (which will apply between you and the retailer) and Dell’s end user 

contract terms. Dell may also provide an additional hard ware warranty–full details of the Del lend user contract and 

warranty terms can be found by going to Dell.com, selecting your country from the list at the bottom of the “home” 

Page and then clicking the” terms and conditions” link for the end user terms or the” support” link for the warranty 

terms.

For non-U.S. customers:

Dell-branded products that are sold and used are subject to applicable national consumer legal rights, the terms of any 

retailer sale agreement that you have entered into (which will apply between you and the retailer) and Dell’s warranty 

terms. Dell may also provide an additional hardware warranty – full details of Dell’s warranty terms can be found by 

going to Dell.com, Selecting your country from the list at the bottom of the “home” page and then clicking the “terms 

and conditions” link or the” support” link for the warranty terms.

Dell.com/terms
Dell.com/terms
Dell.com
Dell.com



