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1
Introduction
Dell OpenManage Connection for IBM Tivoli Netcool/OMNIbus provides event monitoring and console launch 
capabilities for:

• Dell PowerEdge and PowerVault systems from 9th generation (9G) to 12th generation (12G). All the existing 
generation systems support an agent-based, in-band mode using Dell OpenManage Server Administrator 
(OMSA). The 12G systems also support an agent-free, out-of-band mode, using Integrated Dell Remote Access 
Controller 7 (iDRAC7).

• Integrated Dell Remote Access Controller7 (iDRAC7), Integrated Dell Remote Access Controller 6 (iDRAC6), and 
Dell Remote Access Controller 5 (DRAC5) for Dell PowerEdge and PowerVault systems from 9G to 12G.

• Dell Chassis: Dell PowerEdge M1000e (Dell Chassis Management Controller), Dell PowerEdge VRTX (VRTX 
Chassis Management Controller), and Dell PowerEdge 1955 (Dell Remote Access Controller/Modular Chassis).

• Dell Storage Devices: Dell PowerVault MD Storage Arrays and Dell EqualLogic Storage Arrays.

• Dell one to one Console launches:

– Dell OpenManage Server Administrator (OMSA) Console

– Dell OpenManage Server Administrator (OMSA) Web Server Console

– Dell Remote Access Controller (DRAC) Console

– Integrated Dell Remote Access Controller (iDRAC) Console

– Dell Chassis Management Controller (CMC) Console

– Dell PowerEdge VRTX Chassis Management Controller (VRTX CMC) Console

– Dell EqualLogic Group Manager Console

– Dell PowerVault Modular Disk Storage Management (MDSM) console

• Dell OpenManage Essentials (OME) Console

• Dell 12G Server Trap Configuration Information Console

NOTE: This guide is intended for system administrators who are familiar with IBM Tivoli Netcool/OMNIbus 7.3.1 
and IBM Tivoli Netcool/OMNIbus 7.4.

NOTE: Dell Out-of-Band (OOB) 12G servers and Integrated Dell Remote Access Controller 7 (iDRAC7) are used 
interchangeably in the document.

NOTE: This document contains information on the prerequisites and supported software necessary for installing 
Dell OpenManage Connection Version 2.1 For IBM Tivoli Netcool/OMNIbus. Before installing this version of Dell 
OpenManage Connection Version 2.1 For IBM Tivoli Netcool/OMNIbus, download the latest document from 
dell.com/support/manuals. For more information on accessing documents, see Accessing Documents From Dell 
Support Site.

Accessing Documents From Dell Support Site
To access the documents from Dell Support site:
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1. Go to dell.com/support/manuals. 

2. In the Tell us about your Dell system section, under No, select Choose from a list of all Dell products and click 
Continue. 

3. In the Select your product type section, click Software and Security. 

4. In the Choose your Dell Software section, click the required link from the following:

– Client System Management

– Enterprise System Management

– Remote Enterprise System Management

– Serviceability Tools

5. To view the document, click the required product version.

NOTE: You can also directly access the documents using the following links:

• For Enterprise System Management documents — dell.com/openmanagemanuals 

• For Remote Enterprise System Management documents — dell.com/esmmanuals 

• For Serviceability Tools documents — dell.com/serviceabilitytools

• For Client System Management documents — dell.com/OMConnectionsClient 

• For OpenManage Connections Enterprise systems management documents — dell.com/
OMConnectionsEnterpriseSystemsManagement

• For OpenManage Connections Client systems management documents — dell.com/OMConnectionsClient 
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2
Prerequisites
Complete the following prerequisites.

Requirements for the Managing System
The following table lists the requirements for integrating the Dell OpenManage Connection on the systems where the 
Netcool/OMNIbus 7.3.1 or Netcool/OMNIbus 7.4 components are installed.
Table 1. IBM Netcool/OMNIbus Component Requirements

Component Requirement Purpose

Probes Configure the MTTrapd Simple 
Network Management Protocol 
(SNMP) probe and the Netcool/
OMNIbus Knowledge Library (NcKL).

To receive and process the SNMP 
traps sent by Dell devices.

ObjectServer Install and configure the confpack 
utility.

To import Dell integration automation 
triggers, tools, menus, and conversion 
classes.

Desktop Make sure that the SNMP 
communication between the desktop 
and Dell devices is established.

To retrieve the required information 
from Dell devices.

Web GUI Install and configure the OMNIbus 
web GUI and WAAPI.
Make sure that the SNMP 
communication channel between the 
web GUI server and the managed Dell 
systems is established.

To support Dell tools available for Dell 
OpenManage Connection.
To retrieve the required information 
from Dell devices.

Requirements for the Managed System
The following table lists the requirements for the systems that are managed by Dell OpenManage Connection.
Table 2. Managed System Requirements

Dell Devices Requirement

Dell Servers Running Windows • OMSA versions 6.5–7.3
• SNMP Service

Dell Servers Running Linux • OMSA versions 6.5–7.3
• SNMP Service

Dell Servers Running ESXi • ESXi version 4.0 U3 and later
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Dell Devices Requirement

• OMSA versions 6.5–7.3
• SNMP Service

Dell OOB Servers (iDRAC7) • Firmware versions 1.31.30–1.40.40

iDRAC6 Modular • Firmware versions 3.40–3.50

iDRAC6 Monolithic • Firmware versions 1.90–1.95

DRAC5 • Firmware versions 1.5–1.65

DRAC/MC • Firmware versions 1.5–1.6

CMC • Firmware versions 4.3.1–4.45

VRTX CMC • Firmware version 1.0

Dell EqualLogic Storage Arrays • Firmware versions 5.2–6.0

Dell PowerVault MD Storage Array Systems • Firmware versions 07.80.62.60, 07.84.44.60 and 
07.84.47.60

NOTE: Dell EqualLogic Storage Arrays refers to Dell EqualLogic PS Series.

Dell OpenManage Connection for Netcool/OMNIbus File and Folder 
Details
The Dell OpenManage Connection for Netcool/OMNIbus is packaged as a zip file. This is applicable to systems running 
Windows and Linux. You can download the Dell_OpenManage_Connection_for_OMNIbus_v2_1.zip file from dell.com/
support. When you extract the zip file, the following folders and files are extracted:

• desktop_integration

• objectserver_integration

• probe_integration

• webgui_integration

• Dell_OMC_2_1_For_IBM_OMNIbus_IG.pdf — contains the procedure to install Dell OpenManage Connection 
for IBM Netcool/OMNIbus.

• Dell_OMC_2_1_For_Omnibus_ReadMe.txt — contains the details of the new features, system requirements for 
installing Dell OpenManage Connection for IBM Netcool/OMNIbus, installation prerequisites, and so on.

• license_en.txt — contains the license agreement for IBM Netcool/OMNIbus.

Deploy the contents of the folders on the corresponding Netcool/OMNIbus components to monitor the supported Dell 
devices.
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Integration Details for Netcool/OMNIbus Components

The following table lists the Netcool/OMNIbus components and the Integration folders for Dell OpenManage 
Connection. Deploy the integration files of Dell OpenManage Connection from the corresponding folder to the Netcool/
OMNIbus components folder.

Table 3. Netcool/OMNIbus Components

Component Integration Folders

probe_integration Contains the rules and lookup table files for servers, OOB servers, 
DRAC/MC, iDRAC6, DRAC5, CMC, VRTX CMC, Dell EqualLogic storage 
arrays, and Dell PowerVault MD Storage Arrays.

objectserver_integration Contains the exported Dell integration automation triggers, tools, 
menus, and conversion classes.

desktop_integration Contains utilities or tools that you require for:

• Configuring the SNMP community name string.
• Launching the Server Administrator console from the Netcool/

OMNIbus desktop.
• Launching the iDRAC7 console from the Netcool/OMNIbus 

desktop.
• Launching the CMC console from theNetcool/OMNIbus 

desktop.
• Launching the VRTX CMC console from the Netcool/OMNIbus 

desktop.
• Launching the DRAC/MC, iDRAC6, and DRAC5 console from the 

Netcool/OMNIbus desktop.
• Launching the Dell 12G Server Trap Configuration Information 

from the Netcool/OMNIbus desktop.

NOTE: This integration is not applicable to EqualLogic and Common 
Dell Tools.

webgui_integration Contains the Dell integration tools, menus, and applications that you 
require for:

• Configuring the SNMP community name string.
• Launching the Server Administrator console from the Netcool/

OMNIbus web GUI.
• Launching the Server Administrator web server console from 

the Netcool/OMNIbus web GUI.
• Launching the EqualLogic Group Manager console from 

Netcool/OMNIbus web GUI.
• Launching the iDRAC console from the Netcool/OMNIbus web 

GUI.
• Launching the CMC console from the Netcool/OMNIbus web 

GUI.
• Launching the VRTX CMC console from the Netcool/OMNIbus 

web GUI.
• Launching the DRAC5, iDRAC6, and DRAC/MC console from the 

Netcool/OMNIbus web GUI.
• Launching the OpenManage Essentials (OME) console from the 

Netcool/OMNIbus web GUI.
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Component Integration Folders

• Launching the MDSM console from the Netcool/OMNIbus web 
GUI.

• Launching the Dell 12G Server Trap Configuration Information 
console from the Netcool/OMNIbus web GUI.

• Launching the Dell Connections License Manager (DCLM) 
console from the Netcool/OMNIbus web GUI.
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3
Installing Dell OpenManage Connection for 
Netcool/OMNIbus
To install Dell OpenManage Connection for Netcool/OMNIbus, you must extract the component-specific files on the 
systems where you have installed the Netcool/OMNIbus components and deploy them. For more information on 
extracting component-specific files, see Integration Details for Netcool/OMNIbus Components.

Before you begin deploying the files:

1. Download the Dell_OpenManage_Connection_for_OMNIbus_v2_1.zip file from dell.com/support and extract the 
contents to a folder. For more information on contents of the zip file, see Dell OpenManage Connection for Netcool/
OMNIbus File and Folder Details.

NOTE: You can extract the contents of the zip files as per your monitoring requirement.

2. Log in as Netcool administrator on any system where you have installed any of the Netcool/OMNIbus components.

Installing Probe Integration
The probe integration folder contains rules, lookup, and version files for the supported Dell devices.

To deploy the integration of Server, iDRAC7, iDRAC6, DRAC5, DRAC/MC, CMC, Dell PowerEdge VRTX CMC, Dell 
EqualLogic storage arrays, and MD Array traps:

1. Copy the dell folder under probe_integration and place it under the %NC_RULES_HOME%\include-snmptrap folder 
on the system where you have installed the Probe component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

2. Navigate to the %NC_RULES_HOME% folder, open the $NC_RULES_HOME\snmptrap-rules.file and 
perform the following steps:

a. Append the following command in the include rules section:
include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.rules"

b. Append the following command in the include lookup table section:
include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.lookup"

3. Ensure that the copied dell folder and the files under it have permissions for the probe rules in accordance with the 
IBM guidelines. For more information, see IBM Netcool/OMNIbus documentation.

4. Perform the followings steps:
Server traps

a. Uncomment the dell-StorageManagement-MIB.include.snmptrap.lookup file include 
statement in the dell.master.include.lookup file.

b. Uncomment the dell-MIB-Dell-10892.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

c. Uncomment the dell-StorageManagement-MIB.include.snmptrap.rules file include 
statement in the dell.master.include.rules file.

d. Uncomment the dell-MIB-Dell-10892.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.
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EqualLogic traps

a. Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.lookup file include 
statement in the dell.master.include.lookup file.

b. Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.lookup file include statement in 
the dell.master.include.lookup file.

c. Uncomment the equalLogic-SCSI-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

d. Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.rules file include statement 
in the dell.master.include.rules file.

e. Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.rules file include statement in 
the dell.master.include.rules file.

f. Uncomment the equalLogic-SCSI-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

g. Uncomment the equalLogic-ISCSI-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

OOB server traps

a. Uncomment the dell-IDRAC-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b. Uncomment the dell-IDRAC-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

CMC , VRTX CMC, and DRAC (iDRAC6, DRAC5, DRAC/MC) traps

a. Uncomment the dell-RAC-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b. Uncomment the dell-RAC-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

PowerVault MD Storage Array traps

a. Uncomment the dell-MDStorageArray-MIB.include.snmptrap.lookup file include statement 
in the dell.master.include.lookup file.

b. Uncomment the dell-MDStorageArray-MIB.include.snmptrap.rules file include statement in 
the dell.master.include.rules file.

5. Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Installing ObjectServer Integration
The objectserver_integration folder contains the files:

• delldevice_confpack_v_2_1.jar — jar file that contains the exported Dell intergration automation triggers, tools, 
menus, and conversion classes for Servers, iDRAC7 server, CMC, VRTX CMC, DRAC5, iDRAC6, DRAC/MC, Dell 
EqualLogic Storage Arrays, Dell PowerVault MD Storage Arrays, Dell Connections Licence Manager (DCLM), 
and common tools such as Dell OpenManage Essentials (OME).

• delldevice_int_objectserver.ver — version file for integration.

To deploy the Dell integration components on the system that hosts the ObjectServer:

1. Run the following command with the required security credentials to access the OMNIbus ObjectServer:
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a. On systems running Windows:
%OMNIHOME%\bin\nco_confpack.bat -import -server <ObjectServer> -user 
<username> -password <password> -package <copiedfolder>
\delldevice_confpack_v_2_1.jar

b. On systems running Linux:
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
delldevice_confpack_v_2_1.jar

NOTE: By default, ObjectServer is NCOMS.

NOTE: If the nco_confpack command displays the Unsupported Operating System error, see 
ibm.com/support/docview.wss?crawler=1&uid=swg1IV28036, for resolution.

2. In the Event List on the desktop, click File → Resync → All.
This action synchronizes the newly added menu items for the Dell tools and conversion classes that are updated 
from the jar files.

NOTE: Resync can be performed only for ObjectServer integration.

3. In the %OMNIHOME% directory on the system where the ObjectServer is installed, copy the 
delldevice_int_objectserver.ver file.

NOTE: On systems running Linux, use the $OMNIHOME directory.

4. Restart the web GUI.

NOTE: To reconfigure Dell tools for 64–bit IBM Tivoli Netcool/OMNIbus 7.4 on a system running 64–bit linux, 
see Reconfiguring Dell tools for IBM Tivoli Netcool/OMNIbus 7.4 on a system running 64–Bit linux.

Reconfiguring Dell tools for IBM Tivoli Netcool/OMNIbus 7.4 on a system running 64–Bit 
linux

Reconfigure these tools when installing this version of Dell OpenManage connection for IBM Tivoli Netcool/OMNIbus 
Version 7.4 on a system running 64-Bit linux:

• LaunchDellOpenManageServerAdministratorConsole 

• LaunchDellRemoteAccessControllerConsole

• LaunchDelliDRACConsole

• LaunchDellVRTXCMCConsole

• LaunchDellChassisManagementControllerConsole

• Launch12GTrapConfigurationConsole

To reconfigure, provide the required security credentials to access the OMNIbus ObjectServer and log in to the 
ObjectServer.

1. In the Configuration window, select Menu → Tools.

2. Double-click the Tools on the right pane to launch the Tool details window.

3. Click the executable tab and edit the following string:
$(NCHOME)/platform/linux2x86/jre_1.6.7/jre/bin/java

to
$(NCHOME)/platform/linux2x86/jre64_1.6.0/jre/bin/java
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Configuring Dell Server Administrator Web Server Console on the ObjectServer

The Dell Server Administrator Web Server Console uses the configured URL to launch the console in the default 
browser.

To configure the Web Server Console URL on systems running Windows and Linux:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. On systems running Windows, double-click Launch Dell Server Administrator Web Server Console (Windows) on 

the right pane to launch the Tool Details window.
On systems running Linux, double-click Launch Dell Server Administrator Web Server Console on the right pane to 
launch the Tool Details window.

4. Click the executable tab and edit the following command:
https://<Server Administrator Web Server Host/IP>:<Server Administrator Web 
Server PORT>/omalogin.html?managedws=false&mnip=@Node

You must provide the IP address and the port of the Server Administrator Web Server. For example: https://
11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node. For more information, see the Server 
Administrator documentation.

Configuring OpenManage Essentials Console on the ObjectServer

The OME console uses the configured URL to launch the console in the default browser.

To configure the OME console URL on systems running Windows:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. Double-click Launch Dell OpenManage Essentials Console (Windows) on the right pane to launch the Tool Details 

window.
4. Click the executable tab and edit the following command:

https://<OpenManage Essentials Host/IP>:<OpenManage Essentials PORT>

You must provide the IP address and the port of the OpenManage Essentials. For example: https://
11.95.145.156:2607/. For more information, see the OpenManage Essentials User's Guide at dell.com/support/
manuals.

Configuring Dell PowerVault Modular Disk Storage Manager Console on the ObjectServer

The Dell PowerVault Modular Disk Storage Manager (MDSM) console uses the configured URL to launch the console in 
a separate window.

To configure the MDSM console URL on systems running Windows and Linux:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. Double-click Launch Dell Modular Disk Storage Manager on the right pane to launch the Tool Details window.
4. Click the executable tab and edit the following command:

– On systems runningWindows
C:\\Program Files (x86)\\Dell\\MD Storage Software\\MD Storage Manager\
\client\\Modular Disk Storage Manager Client.exe
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– On systems running Linux
/opt/dell/mdstoragesoftware/mdstoragemanager/client/SMclient

For more information, see the Modular Disk Storage Manager User's Guide at dell.com/support/manuals.

Configuring Dell Connections License Manager Console on the ObjectServer

The Dell Connections License Manager (DCLM) console on the Object Server uses the configured URL to launch the 
console in the default browser. To configure the DCLM Console URL on systems running Windows and Linux:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. On systems running Windows, double-click Launch Dell Connection License Manager Console (Windows) on the 

right pane to launch the Tool Details window.
On systems running Linux, double-click Launch Dell Connection License Manager Console on the right pane to 
launch the Tool Details window.

4. Click the executable tab and edit the following command:
http://<DCLM IP/Host>:<DCLM Port>/DellLicenseManagement

You must provide the IP address and the port of the Connection License Manager. For example: http://
DCLM.domain.com:8544/DellLicenceManagement. For more information, see the Dell Connection License Manager 
documentation.

Installing Desktop Integration
The desktop_integration folder for Dell devices contains the following files:

• dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar — configures the SNMP community name string.
• dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar — launches the consoles of the supported Dell devices.
• snmp4j-2.1.0.jar — SNMP Helper uses this file to establish the SNMP communication with Dell devices.
• dell_config.properties — contains the encrypted SNMP community string.
• delldevice_int_desktop.ver — version file for desktop integration.
• dell_OMNIbus_Connection_KB_Tool_v_2_1.jar — contains Trap Destination configuration information.

To deploy the Dell integration components on the system that hosts the desktop client:

1. Copy the dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar, 
dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar, snmp4j-2.1.0.jar, 
dell_OMNIbus_Connection_KB_Tool_v_2_1.jar, and dell_config.properties files in the %OMNIHOME% directory on 
the system where you have installed the desktop client.

NOTE: On systems running Linux, use the $OMNIHOME directory.

2. In the %OMNIHOME% folder on the system where you have installed the desktop client, copy the 
delldevice_int_desktop.ver file.

3. Configure the SNMP Community using the Dell SNMP Configurator utility. For more information, see Dell SNMP 
Configurator Utility.

4. Add an environmental variable called OMNIBROWSER and set it to the path of the default or desired browser.

NOTE: This is applicable to systems running Windows and systems running Linux.

Installing Web GUI Integration
The import sub folder within the webgui_integration folder contains the following files and sub folders:
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• config — Contains the cgi-bin folder with the following files:

– omsalauncher_linux.cgi

– omsalauncher_nt.cgi

– idraclauncher_linux.cgi

– idraclauncher_nt.cgi

– cmclauncher_linux.cgi

– cmclauncher_nt.cgi

– vrtxcmclauncher_linux.cgi

– vrtxcmclauncher_nt.cgi

– draclauncher_linux.cgi

– draclauncher_nt.cgi

– kblauncher_linux.cgi

– kblauncher_nt.cgi

– eqllauncher_nt.cgi

– eqllauncher_linux.cgi

• dell_config.properties — Contains the encrypted SNMP community string.

• dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar — Configures the SNMP community name string.

• dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar — Launches the OpenManage Server Administrator 
(OMSA), Integrated Dell Remote Access Controller (iDRAC), Dell CMC, VRTX CMC, and DRAC (iDRAC6, DRAC5, 
and DRAC/MC) URLs.

• delldevice_int_webgui.ver — Version file for web GUI integration.

• export.xml — Exports menus and tools and for registering cgi scripts.

• snmp4j-2.1.0.jar — SNMP Helper uses this file to establish the SNMP Communication with Dell devices.

To deploy the Dell integration components on the system that hosts the web GUI:

1. Copy the dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar, 
dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar, snmp4j-2.1.0.jar, and dell_config.properties files in the <Web 
GUI home directory> on the system where you have installed the web GUI component.

2. Configure the SNMP Community using the Dell SNMP Configurator utility. For more information, see Dell SNMP 
Configurator Utility.

3. On the system where the web GUI component is installed, in the <Web GUI home directory>, copy the 
delldevice_int_webgui.ver file.

4. Navigate to the import folder in the location where you have extracted webgui_integration folder and run the 
following command for each integration:
On systems running Windows:
<Web GUI home directory>\waapi\bin\runwaapi -host <hostname> -user <Web GUI 
username> -password <Web GUI password> -file export.xml

On systems running Linux:
<Web GUI home directory>/waapi/bin/runwaapi -host <hostname> -user <Web GUI 
username> -password <Web GUI password> -file export.xml

5. If the Web GUI component is installed in a non default location or a location other than %NCHOME%\..\tipv2 
for systems running Windows and $NCHOME\..\tipv2 on systems running Linux, then run the following 
command:
On systems running Windows:
ln –sf $NCHOME/../tipv2 <Actual TIPHOME location>
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On systems running Linux:
mklink /J %NCHOME%\..\tipv2 <Actual TIPHOME location>

NOTE: The Actual TIPHOME location is the custom path where the Web GUI is installed.

For example:

If the WebGUI component is installed on
 /opt/IBM/myWebGUI/tipv2 

then the run the command
"ln -sf $NCHOME/../tipv2 /opt/IBM/myWebGUI/tipv2"

Dell SNMP Configurator Utility

Using the Dell SNMP Configurator utility, you can set the SNMP community string for desktop and web GUI.

NOTE: Once the community string is configured using the Dell SNMP Configurator utility, the same community 
string is used for OMSA, CMC, VRTX CMC, iDRAC7, and DRAC (iDRAC6, DRAC5, and DRAC/MC) console launches.

Related Links:

• Using the SNMP Configurator Utility for Desktop
• Using the SNMP Configurator Utility for Web GUI

Using the SNMP Configurator Utility for Desktop

To use the SNMP Configurator Utility to set the SNMP community string:

1. Navigate to the %OMNIHOME% directory on the system where the Desktop component is installed.
2. Run the following command for Desktop:

a) On systems running Windows:
%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java -
Ddell.config.path=desktop -classpath %NCHOME%\omnibus
\dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar;%NCHOME%\omnibus
\snmp4j-2.1.0.jar com.dell.openmanage.connections.SnmpConfigurator

b) On systems running Linux:
$NCHOME/platform/<specificplatform>/jre_1.6.7/jre/bin/java -
Ddell.config.path=desktop -classpath $NCHOME/omnibus/
dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar:$NCHOME/omnibus/
snmp4j-2.1.0.jar com.dell.openmanage.connections.SnmpConfigurator

Using the SNMP Configurator Utility for Web GUI

To use the SNMP Configurator utility to set the SNMP community string:

1. Navigate to the web GUI Installation directory on the system where the web GUI component is installed.
2. Run the following command for web GUI:

a) On systems running Windows:
<Tivoli Integrated Portal home directory>\java\jre\bin\java -
Ddell.config.path=webgui -classpath %NCHOME%\omnibus_webgui
\dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar;%NCHOME%
\omnibus_webgui\snmp4j-2.1.0.jar 
com.dell.openmanage.connections.SnmpConfigurator

b) On systems running Linux:
<Tivoli Integrated Portal home directory>/java/jre/bin/java -
Ddell.config.path=webgui -classpath $NCHOME/omnibus_webgui/
dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar:$NCHOME/
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omnibus_webgui/snmp4j-2.1.0.jar 
com.dell.openmanage.connections.SnmpConfigurator

Updating the Dell Tools Menu on the Web GUI Server

To update the Dell Tools menu on the Alerts menu of the web GUI component:

1. Perform the following steps to edit the Alert menu:
a) Click Administration → Event Management Tools.
b) Navigate to Menu Configuration.
c) Select Alerts from the Available menus on the right pane.
d) Click Modify.
e) Select menu from the Available items drop-down list.
f) Add Dell Tools to the Current items.
g) Click Save.

2. Navigate to Administration → Availability → Events → Active Event List (AEL) and refresh the list to synchronize 
the newly added menu items.

3. Right-click on a Dell device alert and make sure that the respective Dell devices are available.

Configuring Dell Server Administrator Web Server Console on the Web GUI

To configure the Launch Dell Server Administrator web server console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellServerAdministratorWebServerConsole on the right pane to launch the Tool Configuration 
window.

4. Edit the following URL:
https://<Server Administrator Web Server Host/IP>:<Server Administrator Web 
Server PORT>/omalogin.html?managedws=false&mnip=@Node

You must provide the IP address and the port of the Server Administrator Web Server. For example: https://
11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node. For more information, see the Server 
Administrator documentation.

Configuring Dell OpenManage Essentials Console on the Web GUI

To configure the Launch Dell OpenManage Essentials console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellOpenManageEssentialsConsole on the right pane to launch the Tool Configuration window.

4. Edit the following URL:
https://<OpenManage Essentials Host/IP>:<OpenManage Essentials PORT>

You must provide the IP address and the port of the OME Web Server. For example: https://11.95.145.156:2607/. For 
more information, see the OpenManage Essentials User's Guide at dell.com/support/manuals.
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Configuring Dell PowerVault Modular Disk Storage Manager Console on the Web GUI

To configure the Launch Dell Modular Disk Storage Manager console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellModularDiskStorageManagerConsole on the right pane to launch the Tool Configuration window.

4. Update the following command if required:
On systems running Windows
"%PROGRAMFILES%\Dell\MD Storage Software\MD Storage Manager\client\Modular 
Disk Storage Manager Client.exe"

Configuring Dell Connections License Manager Console on the Web GUI

To configure the Launch Dell Connections License Manager (DCLM) console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellConnectionsLicenseManagerConsole on the right pane to launch the Tool Configuration window.

4. Edit the following URL:
http://<DCLM IP/Host>:<DCLM Port>/DellLicenseManagement

You must provide the IP address and the port of the Dell Connection License Manager. For example: http://
DCLM.domain.com:8544/DellLicenceManagement. For more information, see the Dell Connection License Manager 
documentation.

Configuring Dell Server Administrator Console on the Web GUI Server on Systems 
Running Linux 

To configure the Launch Dell Server Administrator console on systems running Linux:

1. Log in to the web GUI on systems running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellServerAdministratorConsole.

4. Modify the name of the CGI Script in the URL section to omsalauncher_linux.cgi.

Configuring iDRAC Console on the Web GUI Server on Systems Running Linux 

To configure the Launch iDRAC tool on systems running Linux:

1. Log in to the web GUI on systems running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDelliDRACConsole.

4. Modify the name of the CGI Script in the URL section to idraclauncher_linux.cgi.
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Configuring Dell Chassis Management Controller Console on the Web GUI Server on 
Systems Running Linux 

To configure the Launch ChassisManagement Controller tool on a system running Linux :

1. Log in to the web GUI on a system running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellChassisManagementControllerConsole.

4. Modify the name of the CGI Script in the URL section to cmclauncher_linux.cgi.

Configuring Dell PowerEdge VRTX Chassis Management Controller Console on the Web 
GUI Server on Systems Running Linux 

To configure the Launch VRTXChassisManagement Controller tool on systems running Linux :

1. Log in to the web GUI on systems running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellVRTXChassisManagementControllerConsole.

4. Modify the name of the CGI Script in the URL section to vrtxcmclauncher_linux.cgi.

Configuring Dell PowerVault Modular Disk Storage Manager Console on the Web GUI 
Server on Systems Running Linux

To configure the Launch Dell Modular Disk Storage Manager console on systems running Linux:

1. Log in to the web GUI on systems running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellModularDiskStorageManagerConsole.

4. Update the following command:
"/opt/dell/mdstoragesoftware/mdstoragemanager/client/SMclient"/

Configuring Dell Remote Access Controller Console on the Web GUI Server on Systems 
Running Linux

To configure the Launch Dell Remote Access Controller Console tool on systems running Linux:

1. Log on to the web GUI on systems running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellRemoteAccessControllerConsole.

4. Modify the name of the CGI script in the URL section to draclauncher_linux.cgi.
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4
Upgrading Dell OpenManage Connection for 
Netcool/OMNIbus
To upgrade the Dell OpenManage Connection for Netcool/OMNIbus:

1. Uninstall the existing connection. For more information, see the Dell OpenManage Connection Installation Guide at 
dell.com/support/manuals.

2. Install the latest version using the installation procedure described in Installing Dell OpenManage Connection for 
Netcool/OMNIbus.
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5
Uninstalling Dell OpenManage Connection for 
Netcool/OMNIbus
To uninstall Dell OpenManage Connection for Netcool/OMNIbus you must uninstall or remove the component-specific 
files.

Uninstalling Probe Integration
To uninstall the Probe integration:

1. Navigate to the%NC_RULES_HOME%\include-snmptrap folder on the system where you have installed the Probe 
component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

2. Navigate to $NC_RULES_HOME\snmptrap-rules.file and remove the following commands:

– include "$NC_RULES_HOME/include-snmptrap/dell/
dell.master.include.rules"

– include "$NC_RULES_HOME/include-snmptrap/dell/
dell.master.include.lookup"

3. Delete the dell folder under $NC_RULES_HOME/include-snmptrap.

4. Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Uninstalling ObjectServer Integration
To uninstall the ObjectServer integration:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2. In the Configuration window, select Menu → Tools.

3. Right-click the following tools and click Delete:

– Launch Dell Server Administrator Console

– Launch Dell Server Administrator Web Server Console

– Launch Dell EqualLogic Group Manager Console

– Launch iDRAC Console

– Launch Dell Chassis Management Controller Console

– Launch Dell VRTX Chassis Management Controller Console

– Launch Dell OpenManage Essential Console

– Launch Dell Connections License Manager Console

– Launch Dell Modular Disk Storage Manager Console

– Launch Dell 12G Server Trap Configuration Information

4. In the Configuration window, select Menu → Menus.

23



5. Under the Alerts Menu, select Dell Tools.

6. Right-click Dell Tools and click Delete.

7. In the Configuration window, navigate to Automation Triggers and delete the following triggers:

– dell_omsa_clear

– dell_omsa_deduplicate_clear

– dell_equallogic_clear

– dell_equallogic_deduplicate_clear

– dell_idrac_clear

– dell_idrac_deduplicate_clear

– dell_dclm_clear

– dell_dclm_deduplicate_clear

– dell_mdarray_clear

– dell_mdarray_deduplicate_clear

8. In the Configuration window, navigate to Visual Conversions and expand Class. Right-click the following and click 
Delete:

– Dell Server (2080)

– Dell EqualLogic (2085)

– Dell iDRAC (2088)

– Dell CMC (2086)

– Dell VRTX CMC (2084)

– Dell DCLM (2081)

– Dell DRAC (2087)

– Dell MD Storage Array (2809)

9. In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the file 
delldevice_int_objectserver.ver.

10. Open Event List and select File → Resync → All.

11. Restart the web GUI.

Uninstalling Desktop Integration
To uninstall the desktop integration:

1. Navigate to the %OMNIHOME% directory on the system where you have installed the desktop integration 
components.

2. Perform the following steps:

– Remove the file delldevice_int_desktop.ver

– All Desktop Integration — Remove the following files:

* delldevice_int_desktop.ver

* dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar

* dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar

* snmp4j-2.1.0.jar

* dell_config.properties

* dell_OMNIbus_Connection_KB_Tool_v_2_1.jar
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Uninstalling Web GUI Integration
To uninstall the web GUI integration:

1. Log on to the web GUI.

2. Remove the following files from the webgui_integration folder.

– delldevice_int_webgui.ver

– dell_OMNIbus_Connection_SNMP_Configurator_v_2_1.jar

– dell_OMNIbus_Connection_SNMP_Helper_v_2_1.jar

– snmp4j-2.1.0.jar

– dell_config.properties

3. Navigate to Administration → Event Management Tools → Tool Creation. 

4. Select the following tools and click Delete.

– Launch Dell Server Administrator Console

– Launch Dell Server Administrator Web Server Console

– Launch EqualLogic Group Manager Console

– Launch iDRAC Console

– Launch Dell Chassis Management Controller Console

– Launch Dell VRTX Chassis Management Controller Console

– Launch OpenManage Essentials Console

– Launch Dell Modular Disk Storage Manager Console

– Launch Dell Connection License Manager Console

– Launch Dell 12G Server Trap Configuration Information 

5. Navigate to Administration → Event Management Tools → Menu Configuration. 

6. Under Available menus, select DellTools and click Delete.

7. Navigate to Administration → Event Management Tools → CGI Registry. 

8. Select the following .cgi files, and then click Unregister.

– omsalauncher_linux.cgi

– omsalauncher_nt.cgi

– idraclauncher_linux.cgi

– idraclauncher_nt.cgi

– cmclauncher_linux.cgi

– cmclauncher_nt.cgi

– vrtxcmclauncher_linux.cgi

– vrtxcmclauncher_nt.cgi

– draclauncher_linux.cgi

– draclauncher_nt.cgi

– kblauncher_linux.cgi

– kblauncher_nt.cgi

– eqllauncher_nt.cgi

– eqllauncher_linux.cgi

9. Restart the web GUI.
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6
Contacting Dell

NOTE: If you do not have an active Internet connection, you can find contact information on your purchase invoice, 
packing slip, bill, or Dell product catalog.

Dell provides several online and telephone-based support and service options. Availability varies by country and 
product, and some services may not be available in your area. To contact Dell for sales, technical support, or customer 
service issues:

1. Visit dell.com/support
2. Select your support category.
3. Verify your country or region in the Choose a Country/Region drop-down menu at the top of page.
4. Select the appropriate service or support link based on your need.
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